Süsteeminõuded

Tark- ja riistvara nõuded erinevatele platvormidele LibreOffice’i paigaldamisel:

MS Windows

  • MS Windows 7 SP1, MS Windows 8, MS Windows Server 2012 või MS Windows 10;
  • Intel Pentium’iga ühilduv arvuti (soovitatav on Pentium III, Athlon või uuem);
  • 256 MB RAM (soovitatav 512 MB RAM või enam);
  • Kuni 1.5 GB vaba salvestusruumi;
  • 1024×768 ekraani punktitihedus (kõrgem punktitihedus on soovitatav), vähemalt 256 värvi;
  • superkasutaja õigused tarkvara paigaldamiseks, nende puudumisel on võimalus kasutada kaasaskantavat versiooni;

Teatud tarkvara funktsioonide – kuid mitte kõigi jaoks – on vajalik Java. Java on eriti vajalik kui kasutate andmebaasirakendust Base.

Skriptiga LibreOffice’i paigaldamisel saab määrata vaikimisi avama Microsoft Office’i vormingus dokumente:

  • /msoreg=1 valides LibreOffice’i paigaldamisel selle parameetri, paigaldatakse tarkvara vaikimisi Microsoft Office’i failivormingute jaoks;
  • /msoreg=0 valides LibreOffice’i paigaldamisel selle parameetri, ei paigaldata tarkvara vaikimisi Microsoft Office’i failivormingute jaoks.

Kui sooritate administratiivse paigalduse kasutades setup /a, on vaja veenduda, et fail mmsvc90.dll on süsteemi paigaldatud. See fail on pärast paigaldust vajalik LibreOffice’i käivitamiseks.

Enne uue tarkvara paigaldamist on alati soovitatav teha kasutaja dokumentidest ja andmebaasidest varukoopia.

macOS

  • macOS 10.10 (Yosemite) või uuem;
  • Inteli protsessor;
  • 512 MB RAM (soovitavalt ka rohkem);
  • Kuni 800 MB vaba salvestusruumi;
  • 1024×768 graafika 256 värvi (kõrgem punktitihedus on soovitatav).

Teatud tarkvara funktsioonide – kuid mitte kõigi jaoks – on vajalik Java. Java on eriti vajalik kui kasutate andmebaasirakendust Base.

Enne uue tarkvara paigaldamist on alati soovitatav teha kasutaja dokumentidest ja andmebaasidest varukoopia.

GNU/Linux

  • Linuxi tuum v3.10 või uuem;
  • glibc2 v2.17 või uuem;
  • Pentium PC (Pentium III, Athlon või uuem süsteem);
  • 256 MB RAM (512 MB RAM või enam soovitatav);
  • Kuni 1,55 GB vaba salvestusruumi;
  • X Server 1024×768 punktitihedusega (kõrgem punktitihedus on soovitatav), vähemalt 256 värvi;
  • Gnome 3.18 või kõrgem, koos at-spi 1.32 pakettidega (vajalik toetus tugitehnoloogia [AT] tööriistad), või muu ühilduva töölauakeskkonnaga (nagu KDE jt).

Teatud tarkvarafunktsioonide – kuid mitte kõigi jaoks – on vajalik Java. Java on eriti vajalik kui kasutate andmebaasirakendust Base.

Enne uue tarkvara paigaldamist on alati soovitatav teha kasutaja dokumentidest ja andmebaasidest varukoopia.